Intereting Posts
Как контейнеры докеров разрешают имя хоста других контейнеров докеров, работающих на одной машине? Ошибка закрытой трубы при выполнении sftp в vm с помощью докера Запуск хрома внутри контейнера для докеров Как удалить список серверов Docker (Project Interpreter) на Pycharm Ошибка ответа от демона: контейнер CONTAINER_NAME не работает Rails db: мигрировать с postgres, запущенным в контейнере Как настроить Visual Studio внутри Windows Docker Container на Mac OS? Какова наилучшая практика docker + ufw под Ubuntu Соединение отказало ошибке с селеном, запущенным в докере Проблемы с полем контейнера панели Dockerbeats Ошибка публикации .NET Core: «Не удалось найти msdeploy.exe, установите его и повторите попытку» Arch Linux установить докеры Докер, как сообщить о тесте phpunit, который запускается внутри контейнера Как попасть в контейнер с помощью инструмента GUI (например, Kitematic) в Docker? Не удалось запустить слушателя Oracle в Docker Oracle на Red Hat

Ошибка при запуске quickstart-camelservlet в OpenShift V3 с Fabric8 и Docker

Я следую руководству по началу работы, чтобы запустить Fabric8 на OpenShift V3, и я получаю эту ошибку при запуске mvn fabric8:run в этом примере: http://fabric8.io/v2/example.html . Проект строится правильно и попадает в Docker, но я застрял на этом последнем шаге. Кажется, что в kubernetes.json что-то отсутствует, но я не уверен, почему он не создается или как добавить то, что отсутствует.

Кто-нибудь знает?

Благодарю.

 [INFO] Scanning for projects... [INFO] [INFO] ------------------------------------------------------------------------ [INFO] Building War Quickstart : Camel Servlet 2.2-SNAPSHOT [INFO] ------------------------------------------------------------------------ [INFO] [INFO] --- fabric8-maven-plugin:2.0.30:run (default-cli) @ quickstart-war- camel-servlet --- [INFO] Deploying /app/fabric8/quickstarts/quickstarts/war/camel-servlet/target/classes/kubernetes.json to https://127.0.0.1:8443 [WARNING] Default key managers cannot be initialized: /home/****/.keystore (No such file or directory) [INFO] Creating a service from kubernetes.json namespace name quickstart-camelservlet [WARNING] Default key managers cannot be initialized: /home/****/.keystore (No such file or directory) [ERROR] Failed to create service from kubernetes.json. javax.ws.rs.WebApplicationException: HTTP 422 Service "quickstart-camelservlet" is invalid: metadata.namespace: required value. io.fabric8.kubernetes.api.model.Service@24943658[annotations=<null>,apiVersion=v1beta1,containerPort=io.fabric8.kubernetes.api.model.IntOrString@5b36755c[IntVal=8080,Kind=<null>,StrVal=<null>,additionalProperties={}],createExternalLoadBalancer=<null>,creationTimestamp=<null>,id=quickstart-camelservlet,kind=Service,labels=<null>,namespace=<null>,port=9101,portalIP=<null>,protocol=<null>,proxyPort=<null>,publicIPs=[],resourceVersion=<null>,selector={component=quickStartCamelServlet, group=quickstarts},selfLink=<null>,sessionAffinity=<null>,uid=<null>,additionalProperties={}] javax.ws.rs.WebApplicationException: HTTP 422 Service "quickstart-camelservlet" is invalid: metadata.namespace: required value at io.fabric8.kubernetes.api.ExceptionResponseMapper.fromResponse(ExceptionResponseMapper.java:27) at io.fabric8.kubernetes.api.ExceptionResponseMapper.fromResponse(ExceptionResponseMapper.java:11) at org.apache.cxf.jaxrs.client.ClientProxyImpl.checkResponse(ClientProxyImpl.java:302) at org.apache.cxf.jaxrs.client.ClientProxyImpl.handleResponse(ClientProxyImpl.java:725) at org.apache.cxf.jaxrs.client.ClientProxyImpl.doChainedInvocation(ClientProxyImpl.java:683) at org.apache.cxf.jaxrs.client.ClientProxyImpl.invoke(ClientProxyImpl.java:224) at com.sun.proxy.$Proxy47.createService(Unknown Source) at io.fabric8.kubernetes.api.KubernetesClient.createService(KubernetesClient.java:309) at io.fabric8.kubernetes.api.KubernetesClient.createService(KubernetesClient.java:301) at io.fabric8.kubernetes.api.Controller.applyService(Controller.java:251) at io.fabric8.kubernetes.api.Controller.applyEntity(Controller.java:180) at io.fabric8.kubernetes.api.Controller.applyConfig(Controller.java:197) at io.fabric8.kubernetes.api.Controller.apply(Controller.java:148) at io.fabric8.maven.RunMojo.execute(RunMojo.java:57) at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:132) at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:208) at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:153) at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:145) at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:116) at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:80) at org.apache.maven.lifecycle.internal.builder.singlethreaded.SingleThreadedBuilder.build(SingleThreadedBuilder.java:51) at org.apache.maven.lifecycle.internal.LifecycleStarter.execute(LifecycleStarter.java:120) at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:355) at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:155) at org.apache.maven.cli.MavenCli.execute(MavenCli.java:584) at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:216) at org.apache.maven.cli.MavenCli.main(MavenCli.java:160) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.lang.reflect.Method.invoke(Method.java:606) at org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:289) at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:229) at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:415) at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:356) 

Похоже, что версия 2.0.30 в файле fabric8 не принимает пространство имен по умолчанию, которое является пустой строкой. Вы должны попробовать предыдущую версию плагина. Я пробовал с 2.0.25 и, похоже, работает.